Сценарий
Попълвате атрибут на Microsoft 365 с линк към изображение. Въпреки това, когато добавите атрибута към шаблон за подпис, изображението не се появява в дизайнера на подписа или когато имейлът бъде изпратен.
Причина
Изображение може да не се появи в атрибут по следните причини:
- Хостваният URL за изображението не е публично достъпен.
- Използваният атрибут не е синхронизиран с Exclaimer или, ако използвате персонализиран атрибут, той не е активиран.
- Подписът се рендерира като растерно изображение.
Решение
Изберете опция по-долу, за да видите свързаните инструкции:
Тествайте връзката извън атрибута, като използвате елемента Изображение/Лого в Дизайнера на подписа.
За да тествате видимостта на свързано изображение:
- Добавете елемент Изображение/Лого към вашия шаблон. Това отваря прозореца Изображение/Лого. Това е за тестови цели и по-късно ще бъде премахнато. Не е необходимо да променяте дизайна на шаблона си.
- Изберете радио бутона Ново свързано изображение.
- Въведете връзката към мястото, където е съхранено изображението, в полето URL на свързаното изображение.
Ако изображението се появи в предварителния преглед, връзката е публично достъпна. Ако не се появи, може да е частна.
Прозорецът Изображение/Лого показва изображение, което работи в предварителния преглед.
- Ако вашето изображение е хоствано в Dropbox, уверете се, че връзката ви е настроена на Всеки с тази връзка може да преглежда, когато добавяте изображението към вашия атрибут. За повече информация вижте Как да хоствате изображения с Dropbox.
- Ако вашето изображение е хоствано в Google Drive, уверете се, че връзката ви е настроена на Всеки с връзката под Общ достъп, когато добавяте изображението към вашия атрибут. За повече информация вижте Как да хоствате изображения с Google Drive.
- Ако вашето изображение е съхранено другаде, проверете настройките за поверителност на файла с изображението или сървъра. Те могат да варират в зависимост от използваното уеб хранилище.
- Изберете Отказ, за да премахнете елемента Изображение/Лого.
Exclaimer синхронизира данни с Microsoft 365 автоматично, но когато направите промени, можете да извършите ръчна синхронизация, за да актуализирате синхронизираните данни по-рано.
За да извършите ръчна синхронизация на данни:
- Отидете на страницата Управление на подателя.
- В секцията Стартиране на синхронизация изберете Стартиране на синхронизация. За повече информация вижте Синхронизиране на потребителски данни.

Секцията Стартиране на синхронизация.
Ако използвате персонализирани атрибути, проверете дали настройката Синхронизиране на допълнителни потребителски атрибути е включена.
За да активирате персонализирани атрибути от Microsoft 365:
- Отидете на страницата Управление на подателя.
- В секцията Синхронизиране на допълнителни потребителски атрибути се уверете, че е избран радиобутонът за Azure AD атрибути или Персонализирани атрибути, в зависимост от атрибута, който използвате. За повече информация относно конфигурирането на персонализирани атрибути на Microsoft 365 за Exclaimer вижте Синхронизиране на допълнителни потребителски атрибути.

Секцията Синхронизиране на допълнителни потребителски атрибути.
Ако вашият подпис се визуализира като растерно изображение, свързаното изображение в атрибута няма да работи, тъй като режимът на растерно изображение вгражда изображения по дизайн. Подписите се визуализират като растерни изображения автоматично, ако използвате персонализирани шрифтове или фонова снимка.
Ако използвате персонализирани шрифтове, можете да избегнете визуализацията като растерно изображение, като ги замените с набор от шрифтове.
Ако използвате фонова снимка, можете да избегнете визуализацията като растерно изображение, като я замените с фонова боя.
За да проверите дали вашият подпис се визуализира като растерно изображение:
- Отворете подписа си в Дизайнера на подписи.
- Изберете най-външната рамка, за да изберете целия шаблон. За повече информация относно използването на рамки за избор на елементи в подпис, вижте Оцветени рамки, групиране и наследяване на свойства в Дизайнера на подписи.
- В панела Свойства разширете секцията Визуализация.
- Потвърдете дали Режим на визуализация е зададен на Нормален или Растерно изображение.

Настройката за режим на визуализация в свойствата за визуализация.
- Ако не използвате персонализирани шрифтове или фонова снимка, изберете Нормален, за да промените режима на визуализация.