Сценарий
Вы включили подпись и отправили электронное письмо, но заметили, что подпись не отображается или не применяется в полученном письме.
Вы также могли протестировать это с помощью Тестера подписей, но результаты при отправке живого письма отличаются.
Причина
Одна из распространенных причин этой проблемы заключается в том, что при создании правила передачи и коннекторов через портал Exclaimer была указана группа, и пользователь, с которым возникает проблема, не является членом указанной группы.
Эта проблема также может возникнуть, если есть разница между основным адресом SMTP пользователя и их полем mail в Microsoft 365. Поле mail в Microsoft 365 должно совпадать с их основным адресом SMTP. Однако иногда мы видим случаи, когда поле mail в Microsoft 365 содержит неверные данные (обычно в гибридных средах или при использовании синхронизации с Active Directory).
Решение
Есть три возможных решения этой проблемы - пожалуйста, нажмите на необходимые варианты, перечисленные ниже, чтобы прочитать подробное описание:
Выполните ручную синхронизацию данных, чтобы убедиться, что пользователи и членство в группах синхронизированы из Microsoft 365.
Для этого:
-
Войдите в портал Exclaimer и запустите вашу подписку.
- В левой панели нажмите Configuration, затем выберите Manage User Data.
- В правой панели, под Start Synchronization , находятся соответствующие варианты.
Для подробной информации о том, как это сделать, см. Authorize and Synchronize.
Отправитель должен соответствовать условиям правила транспорта Microsoft 365, которое перенаправляет сообщение в Exclaimer.
Если электронное письмо не перенаправляется, Exclaimer не будет его обрабатывать, и подпись не будет применена.
Чтобы проверить текущие условия правила транспорта Microsoft 365, выполните следующие действия:
Учетные данные глобального администратора Microsoft 365
- Войдите в портал администратора Exchange Online (https://admin.exchange.microsoft.com) в качестве администратора.
Отобразится центр администрирования Exchange.
- В левой навигационной панели выберите Поток почты, затем выберите Правила.
- Дважды щелкните правило транспорта, которое включает отправку сообщений в Exclaimer (обычно оно называется Идентифицировать сообщения для отправки в Exclaimer).
Отобразятся настройки правила.
- Проверьте наличие условия с названием Отправитель является членом… - если оно существует, запишите группу, указанную в качестве значения условия.
Например:
- Убедитесь, что все пользователи, для которых требуется подпись, являются членами этой группы Microsoft 365.
Чтобы решить эту проблему, выполните следующие действия:
- Проверьте, содержит ли поле электронной почты Microsoft 365 неверные данные
- Удалите неверные данные и выполните синхронизацию
Проверьте, содержит ли поле электронной почты Microsoft 365 неверные данные
- Перейдите по адресу http://graphexplorer.azurewebsites.net.
- Войдите и авторизуйте доступ с помощью учетной записи администратора Microsoft 365.
- Обновите следующую ссылку с вашими собственными данными (как указано):
https://graph.windows.net/organisationНапример:
https://graph.windows.net/organisation/users/David.Milward@exclaimersupport.exclaimer.com - Скопируйте и вставьте обновленную ссылку в поле GET.
- Нажмите GET.
- После получения ответа прокрутите вниз и найдите поле mail.
Оно должно содержать неверные данные для пользователя.
Например:
- Если поле mail не содержит основной адрес SMTP пользователя, выполните следующие действия для удаления неверных данных и синхронизации.
Если основной адрес SMTP пользователя отображается в поле mail, пожалуйста, создайте обращение в службу поддержки.
Если вы завершили процесс проверки, описанный выше, и обнаружили неверные данные в поле электронной почты Microsoft 365 mail , выполните описанные ниже действия для устранения проблемы и обеспечения правильного распознавания пользователей Exclaimer.
Удалите неверные данные и выполните синхронизацию
- Откройте Active Directory и удалите псевдоним пользователя, отображаемый в поле mail.
- Выполните синхронизацию с Azure. Это обновит поле mail до основного адреса SMTP пользователя.
- После завершения синхронизации, при необходимости вы можете снова добавить псевдоним пользователя.
- Запустите задачу синхронизации из портала Exclaimer:
-
Войдите в портал Exclaimer и запустите вашу подписку.
-
В левой панели нажмите Configuration, затем выберите Manage User Data.
- В правой панели, под Start Synchronization находятся соответствующие параметры.
Подробную информацию о том, как это сделать, см. в статье Authorize and Synchronize.
После завершения задачи синхронизации, пожалуйста, проведите повторное тестирование.
Если этот процесс не решает проблему, пожалуйста, создайте обращение в службу поддержки.