Cenário
Os números de contacto do utilizador (por exemplo, telefone, fax ou telemóvel) estão definidos nas assinaturas de email. Quando a assinatura é aplicada aos emails, estes números são prefixados com um código de país (por exemplo, +1); no entanto, o código do país não está presente quando verifica os dados do utilizador no portal Microsoft Office 365.
Motivo
O código do país não está presente nos campos de dados do utilizador do Microsoft Office 365, mas o Exclaimer sincronizou-o a partir do seu Microsoft Entra ID (anteriormente Azure AD).
Resolução
Para evitar que o código do país seja incluído nas assinaturas, precisa de atualizar os dados do utilizador no Microsoft Entra ID.
Para isso, siga os passos abaixo:
- Abra um prompt do Windows Powershell com privilégios elevados.
Para executar a janela Powershell com permissões elevadas, clique em Iniciar, depois escreva Powershell – localize o ícone Powershell e clique com o botão direito para escolher Executar como Administrador.
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Execute o seguinte comando:
Connect-MsolService - Prima Enter e especifique o seu administrador global do Office 365.
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Para ver os dados existentes do utilizador no seu Microsoft Entra ID, execute o seguinte comando
Get-MsolUser -UserPrincipalName username@office365domain.com |fl- substitua username@office365domain.com pelo nome do utilizador que deseja atualizar.
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Para alterar os dados do utilizador (como o número de telemóvel), execute o seguinte comando:
Set-MsolUser -UserPrincipalName username@office365domain.com -MobilePhone 555-429-4792- substitua 555-429-4792 pelo número de telemóvel (ou outro) necessário, sem o código do país.
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Para confirmar que os dados do utilizador foram atualizados, execute o seguinte comando:
Get-MsolUser -UserPrincipalName username@office365domain.com |fl- substitua username@office365domain.com pelo nome do utilizador que deseja verificar.
- Depois de estas alterações serem propagadas por todo o Office 365/Microsoft Entra ID, sincronize-as com o Exclaimer.
Por predefinição, a sincronização de dados ocorre uma vez por dia; no entanto, pode executar esta operação manualmente. Para mais informações, veja Como sincronizar dados manualmente.