Cenário
Os números de contato do usuário (por exemplo, telefone, fax ou celular) são definidos nas assinaturas de e-mail. Quando a assinatura é aplicada aos e-mails, esses números são prefixados com um código de país (por exemplo, +1); no entanto, o código do país não está presente quando você verifica os dados do usuário no portal do Microsoft Office 365.
Motivo
O código do país não está presente nos campos de dados do usuário do Microsoft Office 365, mas o Exclaimer o sincronizou do seu Microsoft Azure Active Directory.
Resolução
NOTA: As etapas descritas aqui pressupõem que você já tenha criado uma assinatura de e-mail. Para obter mais informações, consulte como você pode criar uma assinatura de e-mail.
Para evitar que o código do país seja incluído nas assinaturas, você precisa atualizar os dados do usuário no Microsoft Azure Active Directory.
Para fazer isso, siga as etapas abaixo:
- Abra um prompt de comando do Windows PowerShell elevado.
Para executar a janela do PowerShell com permissões elevadas, clique em Iniciar, digite PowerShell - localize o ícone do PowerShell e clique com o botão direito para escolher Executar como administrador.
- Execute o seguinte comando:
Connect-MsolService
- Pressione [Enter] e especifique seu administrador global do Office 365.
- Para visualizar os dados do usuário existentes no seu Microsoft Azure Active Directory, execute o seguinte comando:
Get-MsolUser -UserPrincipalName username@office365domain.com |fl- substitua username@office365domain.com pelo nome do usuário que você deseja atualizar.
-
Para alterar os dados do usuário (como o número de celular), execute o seguinte comando:
Set-MsolUser -UserPrincipalName username@office365domain.com -MobilePhone 555-429-4792- substitua 555-429-4792 pelo número de celular (ou outro) necessário, sem um código de país.
-
Para confirmar que os dados do usuário foram atualizados, execute o seguinte comando:
Get-MsolUser -UserPrincipalName username@office365domain.com |fl- substitua username@office365domain.com pelo nome do usuário que você deseja verificar.
- Assim que essas alterações se propagarem por todo o Office 365/Microsoft Azure Active Directory, sincronize-o com o Exclaimer.
Por padrão, a sincronização de dados ocorre uma vez por dia; no entanto, você pode executar essa operação manualmente. Para obter mais informações, consulte Como sincronizar dados manualmente.