Cenário
O suplemento Exclaimer para Outlook solicita repetidamente aos utilizadores no Outlook Clássico a seguinte mensagem:
Quando isto acontece, o suplemento Exclaimer não consegue inserir automaticamente a assinatura do utilizador no corpo do email, interrompendo a composição normal do email. Reiniciar o Outlook pode temporariamente eliminar o aviso e restaurar a inserção da assinatura, mas o problema pode voltar a ocorrer de forma imprevisível, mesmo depois do utilizador ter iniciado sessão com sucesso.
Motivo
Ao compor um email, o Outlook Clássico necessita que o suplemento Exclaimer autentique o utilizador antes de poder inserir uma assinatura. O suplemento tenta iniciar sessão silenciosamente em segundo plano, mas se isso falhar, o Outlook solicita ao utilizador que inicie sessão novamente. Isto acontece geralmente devido a uma cache local do Web Add-in Framework (WEF) corrompida ou desatualizada no Outlook Clássico, e normalmente não afeta o Novo Outlook ou o Outlook na web.
Resolução
Siga estes passos para resolver o problema:
Reinicie o Outlook depois. Se a mensagem de início de sessão continuar a aparecer, então prossiga com os passos listados abaixo de 1 a 5.
- Feche completamente o Outlook. Certifique-se de que o Outlook está totalmente fechado (incluindo no Gestor de Tarefas, se necessário).
- Abra o Explorador de Ficheiros e navegue até: C:\Users\<username>\AppData\Local\Microsoft\Office\16.0\
-
Localize a pasta Wef. Renomeie-a ou elimine-a.
Dica! Também pode eliminar a pasta usando o PowerShell. Execute o seguinte script:
Remove-Item "$env:LOCALAPPDATA\Microsoft\Office\16.0\Wef" -Recurse -Force -ErrorAction SilentlyContinue
Isto limpa a cache local do suplemento.
- Reabra o Outlook.
-
Componha um novo email e confirme que a assinatura é inserida automaticamente.
Se o aviso de início de sessão deixar de aparecer, o problema está resolvido.
Se o problema persistir:
- Abra o Outlook.
- Navegue até ao menu Ficheiro e, em seguida, selecione Ajuda.
- Selecione Obter Diagnósticos.
- Selecione Aceitar. Os registos estão normalmente localizados em C:\Users\<username>\Downloads
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Abra o PowerShell e execute o seguinte comando como Administrador, e copie a saída:
Set-ExecutionPolicy -Scope Process -ExecutionPolicy Bypass; Invoke-WebRequest -Uri "https://raw.githubusercontent.com/exclaimerltd/Internal-Support-Scripts/master/AddInChecks.ps1" -OutFile "$env:TEMP\AddInChecks.ps1"; & "$env:TEMP\AddInChecks.ps1" - Abra um ticket de suporte e inclua os registos de diagnóstico dos Passos 3 e 4 e a saída do script PowerShell do Passo 5.
Esta informação ajudará a Equipa de Suporte a investigar mais a fundo os problemas de autenticação e inicialização do Add-in.