Cenário
Está a preencher um atributo do Microsoft 365 com uma imagem vinculada. No entanto, quando adiciona o atributo a um modelo de assinatura, a imagem não aparece no designer de assinaturas ou quando o email é enviado.
Motivo
Uma imagem pode não aparecer num atributo pelos seguintes motivos:
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O URL hospedado da imagem não é público.
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O atributo utilizado não foi sincronizado com o Exclaimer ou, se estiver a utilizar um atributo personalizado, não está ativado.
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A assinatura é renderizada como uma imagem bitmap.
Resolução
Selecione uma opção abaixo para ver as instruções relacionadas:
Teste o link fora do atributo utilizando o elemento Imagem/Logótipo no Designer de Assinaturas.
Para testar a visibilidade de uma imagem vinculada:
- Adicione um elemento Imagem/Logótipo ao seu modelo. Isto abre a janela Imagem/Logótipo. Isto é por motivos de teste e será removido posteriormente. Não é necessário alterar o design do seu modelo.
- Selecione o botão de rádio Nova imagem vinculada.
- Introduza o link para onde a imagem está armazenada no campo URL da Imagem Vinculada. Se a imagem aparecer na pré-visualização, então o link é público. Se não aparecer, pode ser privado.
A janela Imagem/Logótipo a mostrar uma imagem que funciona na pré-visualização.
- Se a sua imagem está hospedada no Dropbox, certifique-se de que o seu link está definido para Qualquer pessoa com este link pode visualizar ao adicionar a imagem ao seu atributo. Para mais informações, consulte Como hospedar imagens usando o Dropbox.
- Se a sua imagem está hospedada no Google Drive, certifique-se de que o seu link está definido para Qualquer pessoa com o link em Acesso geral ao adicionar a imagem ao seu atributo. Para mais informações, consulte Como hospedar imagens usando o Google Drive.
- Se a sua imagem está armazenada noutro local, verifique as definições de privacidade no ficheiro de imagem ou no servidor. Estas podem variar consoante o armazenamento web que está a utilizar.
- Selecione Cancelar para remover o elemento Imagem/Logótipo.
Para realizar uma sincronização manual de dados:
- Aceda à página de Gestão de Remetentes.
- Na secção Iniciar sincronização, selecione Iniciar sincronização. Para mais informações, consulte Sincronizar dados de utilizador.
A secção Iniciar Sincronização.
Se estiver a utilizar atributos personalizados, verifique se a definição de Ativar Atributos Adicionais está ativada.
Para ativar atributos personalizados a partir do Microsoft 365:
- Navegue até à página de Gestão de Remetentes.
- Na secção Ativar Atributos Adicionais, certifique-se de que o botão de opção para Atributos Azure AD ou Atributos Personalizados está selecionado, dependendo do atributo que está a utilizar. Para mais informações sobre como configurar atributos personalizados do Microsoft 365 para a Exclaimer, consulte Ativar Atributos Adicionais.
A secção Ativar Atributos Adicionais.
Se estiver a utilizar fontes personalizadas, pode evitar a renderização como bitmap ao substituir por um conjunto de fontes.
Se estiver a utilizar uma imagem de fundo, pode evitar a renderização como bitmap ao substituir por uma cor de fundo.
Para verificar se a sua assinatura está a ser renderizada como um bitmap:
- Abra a sua assinatura no Designer de Assinaturas.
- Selecione a borda mais externa para selecionar todo o modelo. Para mais informações sobre como utilizar bordas para selecionar itens numa assinatura, consulte Bordas coloridas, agrupamento e propriedades herdadas no Designer de Assinaturas.
- No painel Propriedades, expanda a secção Renderização.
- Confirme se o Modo de Renderização está definido como Normal ou Bitmap.
A definição do Modo de Renderização nas propriedades de Renderização.
- Se não estiver a utilizar fontes personalizadas ou imagens de fundo, selecione Normal para alterar o Modo de Renderização.