Scenariusz
Skonfigurowałeś Exclaimer i używasz OKTA do synchronizacji danych użytkowników z Google Workspace. Niektóre szczegóły użytkowników, takie jak stanowisko, brakuje w podpisach.
Przyczyna
Exclaimer dla Google Workspace korzysta z interfejsu API Google do pobierania danych dla każdego konta i wymaga, aby dane pola miały ustawioną wartość primary: true.
Domyślnie OKTA nie ustawia tej wartości dla atrybutów 'Organizations'.
Rozwiązanie
Aby ustawić dane organizacji jako podstawowe:
- Przejdź do Konsoli administratora Google Workspace - Interfejs API katalogu (https://developers.google.com/admin-sdk/directory/v1/reference/users/get).
- W prawym panelu, w polu userKey, wprowadź adres e-mail użytkownika, którego chcesz sprawdzić.
- Z listy rozwijanej projection wybierz full.
Przykład:
- Gdy szczegóły zostaną uzupełnione, kliknij WYKONAJ.
- Po wyświetleniu monitu, zaloguj się na konto Google Workspace w celu uwierzytelnienia zapytania:
- Skopiuj wymagany parametr, wraz ze wszystkimi podparametrami.
Przykład:
"organizations": [ { "title": "Tytuł", "customType": "", "department": "IT" } - Przejdź do https://developers.google.com/admin-sdk/directory/v1/reference/users/update
- Ustaw userKey jako adres e-mail użytkownika.
- W Ciele żądania określ parametry, które chcesz ustawić.
Przykład:
{ "organizations": [ { "title": "Tytuł", "primary": true, "customType": "", "department": "IT" } ] }
UWAGA! Musisz określić wszystkie podparametry dla Organizacji; w przeciwnym razie zostaną one nadpisane pustymi wartościami. - Kliknij WYKONAJ.
- Po wyświetleniu monitu, zaloguj się na konto Google Workspace-Suite w celu uwierzytelnienia zapytania.
- Po wyświetleniu monitu, udziel uprawnienia do Google APIs Explorer:
- Powtórz ten proces dla wszystkich dotkniętych użytkowników.
- Po zakończeniu procesu, zsynchronizuj dane użytkownika w Exclaimer.
UWAGA: Istnieje możliwość dodania atrybutu Primary dla nowo utworzonych użytkowników w OKTA. Aby uzyskać więcej informacji, zapoznaj się z przewodnikiem firm trzecich dotyczącym rozwiązania: https://support.bettercloud.com/s/article/Okta-to-G-Suite-Provisioning-bc88101