Scenariusz
Po wysłaniu e-maila odbiorca zgłasza, że nie widział treści wiadomości, a zamiast tego pojawił się załącznik o nazwie winmail.dat.
Przyczyna
Microsoft używa własnego formatu e-mail o nazwie Transport Neutral Encapsulation Format (TNEF), który działa dobrze w klientach poczty Microsoft. Jednak większość innych klientów poczty, takich jak Gmail, Yahoo itp., nie obsługuje TNEF.
Gdy inne klienty poczty otrzymują wiadomość w formacie TNEF, nie mogą jej poprawnie wyświetlić i pokazują zawartość e-maila jako załącznik o nazwie winmail.dat.
Gdy wiadomość e-mail opuszcza środowisko Microsoft 365, powinna być automatycznie konwertowana do formatu Standardowego e-maila (EML), aby uniknąć tego zachowania.
Rozwiązanie
Aby zapobiec wysyłaniu wiadomości jako załączniki winmail.dat, musisz skonfigurować domyślne ustawienia Zdalnych Domen tak, aby nie używały TNEF.
Możesz wykonać jedną z poniższych opcji – kliknij na wybraną opcję, aby przejść do szczegółowego opisu:
- Połącz się z Exchange Online za pomocą Powershell.
Więcej informacji znajdziesz w instrukcji łączenia się z Exchange Online za pomocą Powershell.
-
Wykonaj następujące polecenie:
Set-RemoteDomain -Identity default -TNEFenabled $false
- Przejdź do Centrum administracyjnego Exchange.
- Zaloguj się przy użyciu danych globalnego administratora.
- Wybierz zdalną domenę o nazwie Domyślna.
- Kliknij Edytuj tekst i zestaw znaków.
- Dla opcji Używaj formatu tekstu sformatowanego (rich-text) wybierz Nigdy.
- Kliknij Zapisz.