Scenariusz
Używasz aplikacji Mail na iOS na urządzeniu mobilnym i wysyłasz e-mail na jedno ze swoich własnych kont. Treść wiadomości się nie ładuje i zamiast tego wyświetla się komunikat „Ta wiadomość nie zawiera treści.” Gdy e-mail jest wysłany do innego odbiorcy lub wyświetlany na innym urządzeniu/kliencie poczty, zawartość wiadomości wyświetla się poprawnie.

Przykład e-maila wyświetlającego błąd.
Przyczyna
Problem występuje, gdy masz skonfigurowane zarówno skrzynki nadawcy, jak i odbiorcy na tym samym urządzeniu z iOS. Na przykład wysyłasz e-mail ze swojego konta Microsoft 365 na konto Gmail i masz dostępne oba skrzynki odbiorcze 365 i Gmail na swoim urządzeniu mobilnym.
Gdy obie skrzynki znajdują się na tym samym urządzeniu z iOS, Apple Mail próbuje pobrać treść wiadomości z lokalnego folderu Elementy wysłane zamiast pobierać ją z serwera poczty. Podpisy Exclaimer używają złożonego HTML, który Apple Mail ma trudności poprawnie wyrenderować z lokalnej kopii, co skutkuje pustą treścią wiadomości. Przy wysyłce do innego odbiorcy lub na innym urządzeniu Apple Mail pobiera wiadomość bezpośrednio z serwera, więc podpis jest wyświetlany poprawnie.
Rozwiązanie
Jest to ograniczenie Apple Mail i nie jest kontrolowane przez Exclaimer.
Zalecamy przeglądanie e-maili wysłanych między Twoimi kontami na innym urządzeniu, aby upewnić się, że e-mail ładuje się poprawnie.