Scenariusz
W środowisku Remote Desktop Services (RDS) skonfigurowanym z kontenerami profili FSLogix, niektórzy użytkownicy zgłaszają, że dodatki Outlook zaczynają mieć problemy z uwierzytelnianiem logowania Microsoft po kilku dniach normalnej pracy, mimo że działają poprawnie zaraz po początkowym zalogowaniu.

Przykładowy obraz pokazujący komunikat o błędzie dodatku.
Przyczyna
Problem jest spowodowany przestarzałymi lub uszkodzonymi tokenami logowania zapisanymi w profilu użytkownika. Ponieważ FSLogix przechowuje %LOCALAPPDATA%, złe tokeny utrzymują się między sesjami i ostatecznie uniemożliwiają dodatkom Outlook logowanie.
Rozwiązanie
Wyczyść zapisany cache logowania dla dotkniętego użytkownika. Po usunięciu poniższych folderów oraz wylogowaniu się i ponownym zalogowaniu do RDS, logowanie dodatku Outlook powinno ponownie działać:
- %LocalAppData%\Microsoft\IdentityCache
- %LocalAppData%\Microsoft\OneAuth
- %LocalAppData%\Packages\Microsoft.AAD.BrokerPlugin_*
Jeśli problem będzie się powtarzał po wyczyszczeniu cache, prosimy o otwarcie zgłoszenia do pomocy technicznej w celu dalszego dochodzenia.