Scenario
Hai configurato Exclaimer e stai utilizzando OKTA per sincronizzare i dettagli degli utenti su Google Workspace. Alcuni dettagli degli utenti, come il Titolo di lavoro, mancano dalle tue firme.
Motivo
Exclaimer per Google Workspace utilizza l'API di Google per interrogare i dati di ciascun account e richiede che i dati del campo abbiano il valore primary: true impostato su di esso.
Di default, OKTA non imposta questo valore per gli attributi 'Organizzazioni'.
Risoluzione
Per impostare i dati dell'Organizzazione come primari:
- Accedi alla Console di amministrazione di Google Workspace - API Directory (https://developers.google.com/admin-sdk/directory/v1/reference/users/get).
- Nel riquadro di destra, in userKey, inserisci l'indirizzo email dell'utente che desideri interrogare.
- Dal menu a discesa projection seleziona full.
Esempio:
- Dopo aver compilato i dettagli, fai clic su ESEGUI.
- Quando richiesto, accedi a un account Google Workspace con privilegi per autenticare la query:
- Copia il parametro richiesto, inclusi tutti i sottoparametri.
Esempio:
"organizations": [ { "title": "Titolo", "customType": "", "department": "IT" } - Vai su https://developers.google.com/admin-sdk/directory/v1/reference/users/update
- Imposta il userKey come l'indirizzo email dell'utente.
- Nel Corpo della richiesta, specifica i parametri che desideri impostare.
Esempio:
{ "organizations": [ { "title": "Titolo", "primary": true, "customType": "", "department": "IT" } ] }
ATTENZIONE! Devi specificare tutti i sottoparametri per l'Organizzazione; altrimenti, verranno sovrascritti con valori vuoti. - Fai clic su ESEGUI.
- Quando richiesto, accedi a un account Google Workspace-Suite con privilegi per autenticare la query.
- Quando richiesto, concedi il permesso a Google APIs Explorer:
- Ripeti questo processo per tutti gli utenti interessati.
- Una volta completato il processo, sincronizza i tuoi dati utente in Exclaimer.
NOTA: È possibile aggiungere l'attributo Primario per gli utenti appena creati in OKTA. Per ulteriori informazioni, consultare una guida di terze parti per una soluzione: https://support.bettercloud.com/s/article/Okta-to-G-Suite-Provisioning-bc88101