Scenario
Hai configurato Exclaimer per la tua tenuta Microsoft 365. Quando invii una email, scopri che non viene consegnata e ricevi un rapporto di non consegna con un messaggio simile:
Motivo
Quando la configurazione lato server (Server-Side) viene eseguita in Exclaimer, le impostazioni di flusso di posta, inclusi i criteri di flusso di posta, i connettori di invio e ricezione e un dominio di certificato sicuro, vengono creati in Exchange Online. Una volta creati, queste impostazioni dovrebbero replicarsi automaticamente su ogni altro server Microsoft Exchange Online nel cluster di server a cui appartiene la tua tenuta Microsoft 365.
Di solito, questa replicazione avviene entro pochi minuti e Microsoft consiglia di concedere un'ora affinché tali modifiche si replichino completamente. Tuttavia, a volte queste impostazioni impiegano molto più tempo o non si replicano affatto.
Dopo che un'email viene inviata a Exclaimer per l'applicazione di una firma, Exclaimer instraderà l'email nuovamente alla stessa tenuta Microsoft 365 utilizzando il record MX per il dominio. Qualsiasi server Exchange nel cluster può provare ad accettare l'email da Exclaimer.
Se il server che cerca di accettare l'email da Exclaimer non ha una copia delle impostazioni di flusso di posta configurate da Exclaimer, non può accettare il messaggio in quanto non soddisfa i criteri imposti dalla configurazione predefinita di Microsoft Exchange Online che non consente il relay di email attraverso server in cui il destinatario non appartiene all'organizzazione. Il server rifiuterà l'email con l'errore 'Accesso al relay negato'.
Risoluzione
Fare clic sulle opzioni richieste elencate di seguito per leggere la descrizione dettagliata:
- Accedi al portale di Exclaimer (portal.exclaimer.com) e Avvia la tua sottoscrizione.
- Apri il menu Impostazioni selezionando l'icona dell'ingranaggio, quindi seleziona Flusso di posta.

- Nel riquadro di destra, sotto Dominio di routing della posta, sono presenti tutte le opzioni rilevanti.

- In Nome del dominio, inserisci il dominio in cui l'email deve essere instradata dopo essere stata elaborata da Exclaimer.
Consigliamo: Utilizzare il dominio .onmicrosoft.com che può essere trovato nell'elenco dei domini nel Centro di amministrazione di Microsoft 365: Centro di amministrazione di Microsoft 365. Questa impostazione è importante e un dominio errato può causare problemi di flusso di posta.
Esempio:
NOTE:
L'email viene instradata nuovamente a un server di posta identificato dal record DNS MX del dominio specificato.
Per garantire che l'email venga instradata correttamente dopo essere stata elaborata da Exclaimer, è necessario specificare un dominio con un record MX che punti verso un server Microsoft Exchange Online per la tua organizzazione.
Il record MX per il nome del dominio (nelle impostazioni del Dominio di routing della posta) dovrebbe specificare un singolo server Exchange Online per la tua tenuta Microsoft 365.
Per verificare il record MX per il tuo nome di dominio, utilizza uno strumento di ricerca DNS, come MXToolbox.
Esempio che mostra il dominio di Exclaimer:

- Fai clic su SALVA per salvare le impostazioni di instradamento della posta.
Per modificare la regola di flusso di posta:
- Accedi al portale di amministrazione di Exchange Online (https://admin.exchange.microsoft.com) come Amministratore.
Il Centro di amministrazione di Exchange viene visualizzato.
- Dal menu di navigazione a sinistra, seleziona Flusso di posta, quindi seleziona Regole.
- In Regole, seleziona la regola Identifica i messaggi da inviare a Exclaimer Cloud.
- Fai clic su Modifica condizioni della regola.
- Nella sezione Applica questa regola se, fai clic sul pulsante aggiungi (+).
Esempio:
- Specifica una condizione per limitare la regola a uno o più utenti di test.
Per esempio, Il mittente è un membro di questo gruppo
- Fai clic su Salva.
Ti consigliamo di provare Passaggio 4 - Ricrea le impostazioni di flusso di posta dopo almeno un'ora dall'ultima creazione delle impostazioni di flusso di posta.
- Accedi al centro di amministrazione di Microsoft 365.
- Naviga su Impostazioni > Domini (https://admin.microsoft.com/Adminportal/Home?source=applauncher#/Domains).
- Trova e seleziona il dominio che termina con smtp.exclaimer.cloud o smtp.excl.cloud.
- Fai clic su Rimuovi dominio.
- Conferma di voler rimuovere il dominio.
- Accedi alla tua sottoscrizione Exclaimer.
- Dalla barra dell'intestazione, seleziona l'icona dell'ingranaggio per aprire il menu Impostazioni, quindi seleziona Flusso di posta.
- Se hai limitato il campo di applicazione della regola di flusso di posta Exclaimer a un gruppo come parte del passaggio 2 sopra, deseleziona Invia tutte le email a Exclaimer, e inserisci il nome del gruppo in Nome del gruppo di test.
NOTA: Se hai creato un nuovo gruppo per questo scopo, dovrai avviare una sincronizzazione manuale dei dati prima di procedere con questi passaggi.
- Dal riquadro di destra, sotto Connetti a Microsoft 365, fai clic su Connetti.
- Completa la configurazione come indicato qui: Applicare alle email da tutti i dispositivi, inclusi i dispositivi mobili, per la sottoscrizione Microsoft 365
Se hai già tentato di forzare la replicazione delle impostazioni del flusso di posta eseguendo nuovamente la procedura guidata di connessione e hai atteso diverse ore affinché avvenga la replicazione e continui a vedere il
Ti consigliamo di aprire un ticket con il supporto Microsoft richiedendo assistenza per replicare le impostazioni del flusso di posta. Gli agenti di supporto Microsoft in passato sono stati in grado di forzare la replicazione per gli inquilini eseguendo uno script dal loro lato.
Se hai bisogno di ulteriore assistenza su questo problema o hai bisogno di un contributo da Exclaimer per il tuo ticket di supporto Microsoft, ti preghiamo di aprire un ticket con il supporto Exclaimer, saremo lieti di aiutarti.