Scenario
Dopo aver completato la configurazione iniziale del connettore Exclaimer, noti che gli indirizzi email degli utenti non mostrano più il loro dominio abituale. Invece, sono stati sostituiti con il dominio predefinito .onmicrosoft.com associato al tuo abbonamento Microsoft 365.
Motivo
I cambiamenti imprevisti agli indirizzi email degli utenti che ritornano al dominio .onmicrosoft.com possono derivare da diversi fattori di configurazione o sincronizzazione in ambienti ibridi, cloud o di sincronizzazione directory.
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Problemi di configurazione ibrida
Se utilizzi sia Microsoft 365 che un server Exchange on-premises, eventuali modifiche recenti o problemi di sincronizzazione possono causare il ritorno degli indirizzi email a .onmicrosoft.com in Microsoft 365. -
Microsoft Entra Connect non configurato correttamente
Se Microsoft Entra Connect (precedentemente Azure AD Connect) non è configurato correttamente, in particolare il campo proxyAddresses nella tua Active Directory locale, gli indirizzi email possono essere modificati durante la sincronizzazione. -
Configurazione del connettore di terze parti
Quando si configurano connettori di terze parti, se l'attributo proxyAddresses non è compilato correttamente, Microsoft 365 può creare o aggiornare gli indirizzi email utilizzando per impostazione predefinita .onmicrosoft.com. -
Cambiamenti del dominio verificato che attivano ProxyCalc
Quando un dominio verificato viene modificato, può attivare ProxyCalc—un processo backend che garantisce che UserPrincipalName e gli indirizzi proxy rimangano allineati in Azure AD. Cambiamenti significativi, come l'aggiornamento di un dominio verificato, possono quindi comportare aggiornamenti automatici agli indirizzi email. -
Configurazione errata in ambiente solo cloud
In una configurazione completamente cloud, se il tuo dominio personalizzato non è impostato come dominio predefinito, Microsoft 365 può assegnare nuovi o aggiornati indirizzi email con .onmicrosoft.com. -
Caselle speciali o disabilitate
Alcuni tipi di caselle di posta—o account disabilitati—possono ricevere indirizzi .onmicrosoft.com se le loro impostazioni SMTP sono mancanti o incomplete in Entra ID.
Risoluzione
Le seguenti soluzioni possono essere utilizzate per correggere il problema degli indirizzi proxy e ripristinare gli indirizzi email interessati. Per ulteriori indicazioni, Microsoft consiglia di contattare il loro team di supporto:
• Permessi amministrativi di dominio
Per verificare gli indirizzi proxy degli utenti:
- Su un server o computer con Active Directory Users and Computers (ADUC) installato, aprire la console ADUC. ADUC è solitamente disponibile sui controller di dominio o sui computer con Remote Server Administration Tools (RSAT) installati.
- Nella console ADUC, andare al menu Visualizza e assicurarsi che sia selezionata la voce Funzionalità avanzate. Questo permette di accedere a proprietà aggiuntive dell’utente, inclusa la scheda Editor attributi.
- Navigare nell’albero della directory per trovare l’account utente. In alternativa, utilizzare la funzione di ricerca per localizzare rapidamente l’utente.
- Fare clic con il tasto destro sull’account utente e selezionare Proprietà. Se la scheda manca, confermare che le Funzionalità avanzate siano abilitate (vedere il punto 2).
- Scorrere la lista degli attributi fino a trovare l’attributo proxyAddresses. Questo attributo elenca tutti gli indirizzi email associati all’account utente, incluso l’indirizzo SMTP principale (indicato come SMTP in maiuscolo) e eventuali indirizzi SMTP secondari (indicato come smtp in minuscolo).
- Verificare che l’indirizzo email principale dell’utente sia correttamente elencato con il dominio aziendale. Controllare eventuali indirizzi secondari, come alias, per confermare se sono validi.
Se è necessario aggiornare i proxyAddresses per più utenti in Active Directory, è possibile utilizzare PowerShell per automatizzare il processo. Questo metodo garantisce che tutti gli utenti abbiano i loro indirizzi email configurati correttamente, il che è particolarmente utile per aggiornamenti di massa.
I proxyAddresses devono essere popolati con gli indirizzi SMTP pertinenti per gli utenti.
• Permessi amministrativi di dominio
• Modulo PowerShell per Active Directory
Per aggiornare gli indirizzi proxy per tutti gli utenti usando PowerShell
- Avvia PowerShell come amministratore per assicurarti di avere i permessi necessari per modificare gli attributi degli utenti in Active Directory.
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Importa manualmente il modulo Active Directory eseguendo il seguente comando:
Import-Module ActiveDirectory - Determina il modello per i nuovi indirizzi proxy. Tipicamente, questo comporta l'uso del nome utente o di un altro attributo per costruire in modo coerente il loro indirizzo email, come 'SMTP:username@yourdomain.com' per l'indirizzo principale e "smtp:alias@yourdomain.com" per eventuali alias.
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Usa Get-ADUser per recuperare gli account utente che necessitano di aggiornamenti. Puoi filtrare gli utenti in base a criteri specifici, come dipartimento o posizione, se necessario. L'esempio seguente recupera tutti gli account utente:
$users = Get-ADUser -Filter * -Properties proxyAddresses -
Scorri ogni account utente e aggiorna l'attributo proxyAddresses secondo le politiche di indirizzi email della tua organizzazione. Lo script seguente imposta un nuovo indirizzo SMTP primario per ogni utente basato sul loro samAccountName. Adatta il modello secondo le esigenze della tua organizzazione:
foreach ($user in $users) {
$newPrimaryAddress = "SMTP:" + $user.samAccountName + "@yourdomain.com"
$newAliasAddress = "smtp:alias." + $user.samAccountName + "@yourdomain.com"
Set-ADUser -Identity $user -Replace @{proxyAddresses=@($newPrimaryAddress, $newAliasAddress)}
}
Questo script costruisce un nuovo indirizzo SMTP primario e un alias per ogni utente, quindi aggiorna l'attributo proxyAddresses con questi valori. Modifica i modelli $newPrimaryAddress e $newAliasAddress secondo necessità per adattarli allo schema degli indirizzi email.
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Dopo aver applicato le modifiche, è consigliabile verificare che gli indirizzi proxy siano stati aggiornati correttamente. Seleziona alcuni account utente a caso e usa il comando del passaggio di verifica iniziale per controllare i valori aggiornati:
Get-ADUser -Identity username -Properties proxyAddresses | Select-Object -ExpandProperty proxyAddressesSostituisci username con il nome utente effettivo dell'account che desideri controllare.
• Privilegi amministrativi nel tuo ambiente Microsoft 365
• Il modulo PowerShell per la gestione di Exchange Online è installato sul tuo sistema
Per reimpostare gli indirizzi email al dominio originale in Microsoft 365 utilizzando PowerShell:
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Apri una nuova sessione PowerShell come amministratore e connettiti a Exchange Online con:
Connect-ExchangeOnline -UserPrincipalName admin@yourdomain.comInserisci le credenziali di amministratore quando richiesto.
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Esamina tutte le cassette postali prima di apportare modifiche. Per recuperare e memorizzare tutti gli utenti delle cassette postali:
$mailboxes = Get-Mailbox -ResultSize Unlimited -
Scorri ogni cassetta postale e imposta l'indirizzo SMTP primario al dominio originale. Assicurati che la parte del dominio sia correttamente impostata sul dominio della tua organizzazione.
foreach ($mailbox in $mailboxes){
$newPrimarySmtp = $mailbox.UserPrincipalName.Replace("@onmicrosoft.com", "@yourdomain.com")
Set-Mailbox -Identity $mailbox.Identity -PrimarySmtpAddress $newPrimarySmtp -EmailAddressPolicyEnabled $false
}
Questo script modifica l'indirizzo SMTP primario per ogni cassetta postale, passando dal dominio @onmicrosoft.com a @yourdomain.com. Il parametro -EmailAddressPolicyEnabled $false viene utilizzato per assicurare che la modifica dell'indirizzo email non venga sovrascritta dalle policy sugli indirizzi email.
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Dopo aver aggiornato gli indirizzi email, è buona pratica verificare che le modifiche siano state applicate correttamente. Seleziona alcune cassette postali a caso e usa il cmdlet Get-Mailbox per controllare l'indirizzo SMTP primario:
Get-Mailbox -Identity username | Select-Object DisplayName, PrimarySmtpAddress
Sostituisci username con il nome utente effettivo della cassetta postale che desideri controllare.