Scenario
Quando una firma viene aggiunta da Exclaimer, in alcuni scenari, il destinatario riceve l'email in formato testo normale. Di conseguenza, la firma viene visualizzata anche in formato testo normale anziché HTML.
Motivo
Il problema si verifica perché il formato del messaggio è stato modificato da HTML a testo normale durante la consegna del messaggio e dopo che è stato elaborato da Exclaimer.
Ciò può accadere per diversi motivi, ma più comunemente:
- Se le impostazioni di configurazione del Remote Domain specificate sul server Microsoft Exchange sono configurate in modo errato.
- Se la proprietà TNEFEnabled è impostata su True, le email inviate a provider che non supportano il formato di incapsulamento neutrale del trasporto (TNEF) (ad esempio, Gmail) verranno visualizzate in formato testo normale. L'email verrà visualizzata anche in formato testo normale se il client di posta elettronica del destinatario non supporta TNEF.
Risoluzione
Fare clic sulle opzioni richieste elencate di seguito per accedere alla descrizione dettagliata:
Per verificare e configurare le impostazioni di configurazione del Remote Domain:
-
Aprire Windows PowerShell e eseguire questo comando come amministratore:
Install-Module -Name ExchangeOnlineManagement
-
Confermare l'installazione di questo modulo PowerShell.
NOTA: Per ulteriori opzioni di installazione, vedere ExchangeOnlineManagement.
- Se si ha l'autenticazione a più fattori abilitata, eseguire questo comando:
Connect-ExchangeOnline -UserPrincipalName <UPN> -ShowProgress $true
Inserire il proprio nome utente in <UPN>. - Se non si ha l'autenticazione a più fattori abilitata, eseguire questo comando:
Connect-ExchangeOnline -Credential $UserCredential -ShowProgress $true
Quando richiesto, inserire la propria password (e il codice di verifica dell'autenticazione a più fattori se richiesto).
Per visualizzare la configurazione corrente del Remote Domain, eseguire il seguente comando:
Se la proprietà ContentType è specificata come MimeText, questo è probabilmente la causa della conversione del formato del messaggio.
La proprietà ContentType dovrebbe essere configurata come MimeHtmlText o MimeHtml, dove:
-
MimeHtml impone il formato HTML.
- MimeHtmlText consente al client di posta elettronica ricevente di decidere il miglior formato per visualizzare il messaggio.
Per modificare la proprietà ContentType, eseguire il seguente comando:
Ad esempio:
Per impostare le impostazioni della proprietà TNEFEnabled:
-
Aprire Windows PowerShell ed eseguire questo comando come amministratore:
Install-Module -Name ExchangeOnlineManagement
-
Confermare l'installazione di questo modulo PowerShell.
NOTA: Per ulteriori opzioni di installazione, vedere ExchangeOnlineManagement.
- Se si ha l'autenticazione a più fattori abilitata, eseguire questo comando:
Connect-ExchangeOnline -UserPrincipalName <UPN> -ShowProgress $true
Inserire il proprio nome utente in <UPN>. - Se non si ha l'autenticazione a più fattori abilitata, eseguire questo comando:
Connect-ExchangeOnline -Credential $UserCredential -ShowProgress $true
Quando richiesto, inserire la propria password (e il codice di verifica dell'autenticazione a più fattori se richiesto).
Eseguire il seguente comando:
Se si dispone di un ambiente di flusso di posta ibrido, potrebbe essere necessario configurare anche le proprietà ContentType e TNEFEnabled sul server Exchange locale.