Relevant Products: Exclaimer Cloud - Signatures for Office 365 | Exclaimer Cloud - Signatures for G-Suite
Scenario
When viewing, replying/forwarding an email that has been sent using plain text format, the signature displays misaligned and without formatting.
Cause
Exclaimer Cloud is based on HTML in the source code. When an email is converted to plain text the HTML formatting is removed. This causes the formatting to be removed as well as displaying images and horizontally aligned elements to appear underneath each other.
Outlook will typically provide a warning about what will be lost when using plain text mode, as they are unsupported.
Due to security reasons, Outlook will also display the full hyperlink when plain text is used - this is so you know where the URL is pointing to.
In this scenario, we know that commas, separators and the address fields would display underneath each other when compared to how they were configured to be side-by-side in the signature template.
Resolution
Method 1
To minimise the issue, we recommend combining the fields into one text box where applicable.
If a field is not required for everyone, we recommend to re-position the field, or create two versions of the field by using conditional visibility as shown in Method 2.
When combining fields, we also recommend including the separators whether they are a pipe, comma, forward slash etc. This will help to minimise the issue and allow the fields to align correctly.
The plain text will now align the text correctly as per the HTML template.
Method 2
Following the same steps as before, however, we would like to ensure that the Company Name and Mobile will hide if they are not available.
We can use conditional visibility, to control the fields further.
To achieve this, add in the Job Title and Telephone number fields into the template while ensuring the rest of the template stays in place.
Apply the formatting required, to match the signature themes as well.
Next, set visibility on the text boxes to the field you want to display - in this instance if Company Name is Visible and if Mobile is visible.
Starting with the Job Title, click on this field and navigate to the visibility option, here we can set the visibility to check if the company name is empty, this field will then show as a single value.
Next. we click on the job title and company name text box and set the visibility to show if the company name is not empty i.e. populated.
This will prevent duplicate data from appearing in the signature template.
Repeat these steps, and apply then to the telephone field, ensuring that the company name is replaced with mobile for the visibility setting.