Сценарий
Контактните номера на потребителя (например, телефон, факс или мобилен) са зададени в електронните подписи. Когато подписът се прилага към имейли, тези номера се предшестват от международен телефонен код (например, +1); обаче, международният код не е налице, когато проверявате данните на потребителя в портала на Microsoft Office 365.
Причина
Международният телефонен код не е налице в полетата за данни на потребителите в Microsoft Office 365, но Exclaimer го е синхронизирал от вашия Microsoft Azure Active Directory.
Решение
ВНИМАНИЕ: Предполага се, че сте вече създали електронна подпис. За повече информация вижте как можете да създадете електронна подпис.
За да предотвратите включването на международния телефонен код в подписите, трябва да актуализирате данните на потребителите в Microsoft Azure Active Directory.
За да направите това, следвайте стъпките по-долу:
- Отворете повишен прозорец на Windows PowerShell.
За да стартирате прозореца на PowerShell с повишени права, щракнете върху Start, след което напишете PowerShell - намерете иконата на PowerShell и щракнете с десния бутон, за да изберете Run as Administrator.
- Изпълнете следната команда:
Connect-MsolService
- Натиснете [Enter] и посочете вашия Office 365 глобален администратор.
- За да видите съществуващите данни на потребителите във вашия Microsoft Azure Active Directory, изпълнете следната команда:
Get-MsolUser -UserPrincipalName username@office365domain.com |fl- заменете username@office365domain.com с името на потребителя, който искате да актуализирате.
-
За да промените данните на потребителя (като мобилния номер), изпълнете следната команда:
Set-MsolUser -UserPrincipalName username@office365domain.com -MobilePhone 555-429-4792- заменете 555-429-4792 с желания мобилен (или друг) номер, без международен телефонен код.
-
За да потвърдите, че данните на потребителя са актуализирани, изпълнете следната команда:
Get-MsolUser -UserPrincipalName username@office365domain.com |fl- заменете username@office365domain.com с името на потребителя, който искате да проверите.
- След като тези промени се разпространят в целия Office 365/Microsoft Azure Active Directory, ги синхронизирайте с Exclaimer.
По подразбиране, синхронизацията на данните се извършва веднъж на ден; обаче, можете да изпълните тази операция ръчно. За повече информация вижте Как да синхронизирате данните ръчно.