EWS connectivity test fails with (501) Not Implemented Error

Problem:

When testing EWS connectivity in any Exclaimer product that uses Exchange Autodiscover (Mail Disclaimers, Signature Manager Exchange Edition, Signature Manager Office 365 Edition or Mail Archiver), the following or similar error is reported:


System.Exception: There was a problem connecting to Exchange using details specified.

The error returned was: The request failed. The remote server returned an error: (501) Not Implemented.. ---> System.ServiceModel.FaultException: The request failed. The remote server returned an error: (501) Not Implemented.
Server stack trace: 

at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)

at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)

at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)

at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:

at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)

at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)

at Exclaimer.MailArchiver.ServiceContract.IProbeConnectivity.RunTest(ExchangeWebServiceConnectionArguments args)

at Exclaimer.MailArchiver.ServiceContract.ConnectivityProbeClient.RunTest(ExchangeWebServiceConnectionArguments args)

at Exclaimer.Capabilities.StoreRules.MailArchiver.Features.JournalMailboxes.EwsConnectionHelper.ValidateConnectionSettings()

at Exclaimer.Capabilities.StoreRules.MailArchiver.Features.JournalMailboxes.UI.JournalMailboxSettingsPanel.btnValidate_Click(Object sender, EventArgs e)

--- End of inner exception stack trace ---

Reason:

This error can occur in environments where a KEMP load balancer is installed to distribute workload and optimize resources, and the load balancer is blocking data.

Solution:

The issue can be resolved by turning off the processing of Continue-100 HTTP packets on the KEMP load balancer.


Further information about this error (and how to resolve it) can be found in the article below:


Exchange Web Services (EWS) and 501 Error - http://c7solutions.com/2014/06/exchange-web-services-ews-and-501-error

Troubleshooting